Eclipse 和 Vim

Eclipse 和 Vim

以前,neo和发布过如何在vim中得到你最喜爱的IDE特性,这是一篇在vim中装一些插件而让Vim拥有IDE的功能,比如代码自动提示等功能。当然,目前,可能强大最好用的IDE就是Eclipse和,而最强大的编辑器又是Vim了,可不可以让这两个东西合二为一呢。没有问题,开源社区的创造力永远不会让你低估。

在Vim中拥有Eclipse的功能,在Eclipse里有Vim的功能,那么eclim是你的选择了。http://eclim.org/ 相关的中文文档。使用eclim,你可以在vim中有Eclipse的功能,也可以在Eclipse中嵌入Vim编辑器。很酷。

_images/java_editor_eclim_view.png

还有一个工具是Vrapper,这个工具是在Eclipse中使用Vim,你只需要在Eclipse的工具栏上点一下那个gvim的按钮就可以了。

http://vrapper.sourceforge.net/home/

(全文完)


关注CoolShell微信公众账号可以在手机端搜索文章

(转载本站文章请注明作者和出处 酷 壳 – CoolShell ,请勿用于任何商业用途)

——=== 访问 酷壳404页面 寻找遗失儿童。 ===——
好烂啊有点差凑合看看还不错很精彩 (10 人打了分,平均分: 4.50 )
Loading...

Eclipse 和 Vim》的相关评论

  1. 用起来确实很不错,特别是调试,但是eclim现在还不能像eclipse里面自动给Java加import,要手动打命令,所以补全的时候还是不如eclipse舒服。

  2. 我安装好eclim后,照提示所说的 运行 /home/mao/java/eclipse/plugins/org.eclim_1.3.5/bin/eclimd 后,
    提示 No eclipse excutable found.
    启动gvim提示:
    Error detected while processing CursorHold Auto commands for “*”
    E117:Unkown function eclim#util#ShowCurrentError
    在安装eclim之前要安装别的插件吗?我是没有安装任何插件的。
    安装eclim出现对话框时,选择了 Override eclipse plugin location
    vimfiles目录选择了 ~/.vim/
    eclipse目录选择了 ~/java/eclipse
    eclim是1.3.5 ,eclipse是Europa
    我的gvim是源安装的,系统是ubuntu

    期待您的回复。

  3. @fengdenanzi
    用Vrapper好点 基本功能都有 以eclipse为主 不麻烦
    eclim官方的说明很详细 仔细读就可以正常安装
    ps:360浏览器真悲剧,eclim官网的导航栏显示不出来,害我纠结了好久..

发表评论

电子邮件地址不会被公开。 必填项已用*标注

*